Olympus-Zone





Cisco IOS

Une version de IOS avec le support IPv6 est requise pour les commandes suivantes. Cet exemple nécessite la présence d'une interface LAN nommé ethernet0.

Note: la commande "ipv6 unicast-routing" est devenue nécéssaire si vous voulez faire du routage (le RA ne fonctionnera pas sans)

Cisco IOS 12.2(2)T

configure terminal
interface tunnel0
 description IPv6 Tunnel Broker
 no ip address
 ipv6 enable
 ipv6 address [votre_ipv6_publique]/127
 tunnel source [votre_ipv4_publique]
 tunnel destination [ipv4_du_tunnel_broker]
 tunnel mode ipv6ip
ipv6 route ::/0 tunnel0
interface ethernet0
 ipv6 address [votre_segment_ipv6]::/64 eui-64
end
write
une autre config :
!
ipv6 unicast-routing
!
interface Tunnel0
description Tunnel vers Nerim
no ip address
ipv6 address [votre_ipv6_publique]/127
ipv6 enable
ipv6 mtu 1280
tunnel source [votre_ipv4_publique]
tunnel destination [ipv4_du_tunnel_broker]
tunnel mode ipv6ip
!
interface Ethernet0
description reseau local
!          ipv4 LAN
ip address 192.168.1.2 255.255.255.0
!          dans le cas du nat
ip nat inside
ip tcp adjust-mss 1412
ipv6 address [une_ip_de_votre_bloc]/64
ipv6 mtu 1280
ipv6 address [une_ip_de_votre_bloc_suivant]/64
ipv6 enable
ipv6 nd ra-interval 60
ipv6 nd ra-lifetime 180
ipv6 nd prefix-advertisement [votre_segment_ipv6]::/64 360 60 autoconfig
no cdp enable
!
ipv6 route [votre_segment_ipv6]::/64 Ethernet0
!          nullrouting
ipv6 route [un_segment_ipv6]::/48 Null0
ipv6 route ::/0 Tunnel0
!



La configuration par défaut des routeurs Cisco sous les IOS en IPv6 comprend une limitation des envois ICMP. C'est un peu l'équivalent de ICMP_BANDLIM sous FreeBSD, sauf que le réglage par défaut est trop important.

Cela a pour effet de pas mal "pourrir" les 'traceroute' que l'on effectue sur le réseau IPv6 dès qu'il y a un routeur Cisco.
Pour être tranquille, appliquer la commande suivante en configuration globale :
routeur(config)#ipv6 icmp error-interval 0

Merci à Raphael Bouaziz (Nerim).

Liens



Auteur
Jean Théry

This Page in your language (Cette page en d'autres langues) :
EnglishFrench (Français)

6Bone Webring
[ Previous 5 Sites | Previous | Next | Next 5 Sites | Random Site | List Sites | Join ]
IPv6 Webring
[ Previous 5 Sites | Previous | Next | Next 5 Sites | Random Site | List Sites | Join ]

Mardi 24 Avril 2018
Load time : 0.117 seconds
Connecté via IPv4 (IPv4 seulement ici IPv6 seulement ici www)
©2001-2018 Olympus-Zone    Webmaster Jean Théry Valid HTML 4.01! Valid CSS!