Olympus-Zone





Linux

Installation du patch :

Testé avec le kernel 2.2.17 & 2.4.5, ça marche correctement. N'utilisez pas le 2.4.4, il est _vraiment_ buggué. Donc, downloadez linux-2.4.5.tar.gz dans /usr/src/. Après, untargz le avec #> tar -xzf linux-2.4.5.tar.gz. Dans le conf (make menuconfig), choissez
Code maturity level options -->
 [*] Prompt for developpement and/or incomplete code drivers
Network Options -->
[*] Kernel/User netlink socket
 <*> Netlink device emulation
[*] TCP/IP Networking
 [*] IP: Multicasting
 <*> IP: Tunneling
 <*> IP: GRE tunnels over IP
 [*] The IPv6 Protocol [& suboptions like EUI-64]
Compilez le (make dep; make bzImage), installez le dans lilo & Rebootez :)

script :

vous avez besoin du package net-tools avec le support ipv6.Les sources peuvent être obtenue sur cette
Adresse

Si vous avez les net-tools IPv6:

	ifconfig t0 up
	ifconfig t0 inet6 tunnel ::[ipv4_du_tunnel_broker]
	ifconfig t1 up
	ifconfig t1 inet6 add [votre_ipv6_publique]/127
	route -A inet6 add ::/0 dev t1
	
Si vous avez le package route2 :
	modprobe ipv6
	ip tunnel add xbone mode sit remote [ipv4_du_tunnel_broker] local [votre_ipv4_publique] ttl 255
	ip link set xbone up
	ip addr add [votre_ipv6_publique]/127 dev xbone
	ip route add ::/0 dev xbone
	ip -f inet6 addr
	

script LAN :

ifconfig eth0 add [IPv6 LAN]/[PREFIXLEN] il est important d'avoir le meme PREFIXLEN sur toutes les machines du LAN.

Routeur

Pour faire de votre machine un routeur IPv6 :

1) utiliser la configuration standard
echo 1 > /proc/sys/net/ipv6/conf/all/forwarding

Auteur
Jean Théry

This Page in your language (Cette page en d'autres langues) :
EnglishFrench (Français)

6Bone Webring
[ Previous 5 Sites | Previous | Next | Next 5 Sites | Random Site | List Sites | Join ]
IPv6 Webring
[ Previous 5 Sites | Previous | Next | Next 5 Sites | Random Site | List Sites | Join ]

Mardi 17 Juillet 2018
Load time : 0.112 seconds
Connecté via IPv4 (IPv4 seulement ici IPv6 seulement ici www)
©2001-2018 Olympus-Zone    Webmaster Jean Théry Valid HTML 4.01! Valid CSS!