Olympus-Zone





Cisco IOS

A version of IOS with the IPv6 support is necessary for the following orders. This example requires the presence of an interface LAN named ethernet0.

Note: the order "ipv6 unicast-routing" became necessary if you want to make routing (RA will not function without this)

Cisco IOS 12.2(2)T

configure terminal
interface tunnel0
 description IPv6 Tunnel Broker
 no ip address
 ipv6 enable
 ipv6 address [youre_ipv6_public]/127
 tunnel source [youre_ipv4_public]
 tunnel destination [ipv4_of_tunnel_broker]
 tunnel mode ipv6ip
ipv6 route ::/0 tunnel0
interface ethernet0
 ipv6 address [youre_segment_ipv6]::/64 eui-64
end
write
other config :
!
ipv6 unicast-routing
!
interface Tunnel0
description Tunnel to Nerim
no ip address
ipv6 address [youre_ipv6_public]/127
ipv6 enable
ipv6 mtu 1280
tunnel source [youre_ipv4_public]
tunnel destination [ipv4_of_tunnel_broker]
tunnel mode ipv6ip
!
interface Ethernet0
description LAN
!          ipv4 LAN
ip address 192.168.1.2 255.255.255.0
!          case of nat
ip nat inside
ip tcp adjust-mss 1412
ipv6 address [une_ip_de_votre_bloc]/64
ipv6 mtu 1280
ipv6 address [une_ip_de_votre_bloc_suivant]/64
ipv6 enable
ipv6 nd ra-interval 60
ipv6 nd ra-lifetime 180
ipv6 nd prefix-advertisement [youre_segment_ipv6]::/64 360 60 autoconfig
no cdp enable
!
ipv6 route [youre_segment_ipv6]::/64 Ethernet0
!          nullrouting
ipv6 route [a_segment_ipv6]::/48 Null0
ipv6 route ::/0 Tunnel0
!



The configuration by defect of routers Cisco under the IOS in IPv6 includes/understands a limitation of sendings ICMP. It is a little the equivalent of ICMP_BANDLIM under FreeBSD, except that the adjustment by defect is too important.

That causes of step badly "to rot" the ' traceroute' that one carries out on the IPv6 network as soon as there is a router Cisco.
To be quiet, apply the following order in total configuration :
routeur(config)#ipv6 icmp error-interval 0

Thanks to Raphael Bouaziz (Nerim).

Links



Author
Jean Théry

This Page in your language (This page in other languages) :
EnglishFrench (Français)

6Bone Webring
[ Previous 5 Sites | Previous | Next | Next 5 Sites | Random Site | List Sites | Join ]
IPv6 Webring
[ Previous 5 Sites | Previous | Next | Next 5 Sites | Random Site | List Sites | Join ]

Friday 24 November 2017
Load time : 0.226 seconds
Connected via IPv4 (IPv4 Only here IPv6 Only here www)
©2001-2017 Olympus-Zone    Webmaster Jean Théry Valid HTML 4.01! Valid CSS!